How to: Fix Adium can’t connect to Yahoo Messenger

| 21 Comments »

Help: Adium can’t connect or is unable to connect to Yahoo! even after restarting the application or the whole OS.

__UPDATE__(6/24/09), Important!

Adium’s latest update includes a fix for this bug so please do download the update and after installation please make sure your connection’s login server is back to the default: scs.msg.yahoo.com, and ports: 5050, that should fix it.

Here’s a quick fix to this problem

  1. Disconnect(or Cancel) if your account is currently connecting.
  2. Change your connection’s login server from scs.msg.yahoo.com to 66.163.181.106, leave port 5050 unchanged. (You can do this by going to File -> (Select your Yahoo! Account) -> Edit Account, you can also do this in the File -> Preferences -> Accounts -> Edit
  3. Try Connecting Again.

That’s It! The steps above should be done to _each_ of your yahoo accounts.

__UPDATE__: This solution works for Pidgin as well so you may want to share this with your pidgin buddies who are experiencing the same problem.

Ciick here to share this solution with others who are experiencing the same problem!


21 Comments on “How to: Fix Adium can’t connect to Yahoo Messenger”

  1. 1 Daniel said at 12:38 AM on June 20th, 2009:

    Worked perfectly – been trying to find a solution for 2 days! Thanks. :)

  2. 2 allyson said at 1:38 AM on June 20th, 2009:

    Thank you – tried multiple other fixes found online and this was the only one that seemed to do the trick.

  3. 3 Timothy said at 9:57 AM on June 20th, 2009:

    Yes, this worked for me! Finally a work around until libpurple can be updated to use yahoo’s new protocol.

  4. 4 james said at 11:25 AM on June 20th, 2009:

    alternatively you can just add the following to your hosts file:

    66.163.181.106 scs.msg.yahoo.com

    I would give details on how to do that, but I believe that if you are not familiar w/ the hosts file, it would be safer to just change the setting in the adium account preferences.

  5. 5 oliver said at 9:16 PM on June 20th, 2009:

    worked for me

    thanks a lot!!!!

    cheers….

  6. 6 Cyber Valdez said at 5:13 AM on June 21st, 2009:

    @james editting your hosts file could possibly lead to some problems in the future _say_ Yahoo! decided to change the ip address used in their protocol.

    Just an update: as pointed out, this solution works for pidgin as well.

  7. 7 surfnux said at 9:26 AM on June 21st, 2009:

    Thanks, you saved me hassles from having to use Yahoo Messenger instead of Adium. Its been two days I keep on waiting for it to connect and now you save my time. Thank you. :)

  8. 8 axn said at 8:05 PM on June 21st, 2009:

    thanks.. it works!

  9. 9 ging said at 10:30 PM on June 21st, 2009:

    thank you ever so much for this! finally! a solution!

  10. 10 Laurie said at 9:49 AM on June 23rd, 2009:

    This solution did NOT work for me.. :(

  11. 11 Wolfling64 said at 1:11 PM on June 23rd, 2009:

    I had it working, and now Adium will not connect to Yahoo! Messenger at all.

    What should I do next??

  12. 12 Cyber Valdez said at 4:39 AM on June 24th, 2009:

    Guys, the new update of adium fixed the issue so just revert back to the original address which is: scs.msg.yahoo.com and port: 5050

  13. 13 Michael said at 3:02 PM on July 2nd, 2009:

    This didnt work for me at all – With the server at scs.msg.yahoo.com, it is eternally stuck on “connecting”, when it’s changed to the number I get some error “connecting to the socket”. I have the newest update, are there any other solutions to try?

  14. 14 Cyber Valdez said at 7:24 AM on July 3rd, 2009:

    @Michael If you have multiple accounts, you may have to set them each individually and pointed back to the original address: scs.msg.yahoo.com and port: 5050

  15. 15 loko said at 7:30 PM on July 4th, 2009:

    tried everything, still cant get it to work..

    weird thing is, it works on my macbookpro..

  16. 16 Lisa said at 12:49 AM on July 22nd, 2009:

    It worked! That was driving me nuts. Thanks!

  17. 17 Morgan said at 1:15 AM on August 5th, 2009:

    It didn’t work… I may have a more serious problem. I am using an older version of Adium, so I can use the Xblaze plugin. When I try to connect to Xfire and Yahoo, the status stays at “Connecting” forever. When I put the IP ^^ in instead of the default Yahoo address, it keeps “…retrying in 5, 4, 3…” I am having no success.

  18. 18 edy said at 1:36 AM on August 10th, 2009:

    These solutions does’nt work for me.. I still get “Could not establish a connection with the server: Access denied: HTTP proxy server forbids port 5050 tunneling”

  19. 19 MG said at 1:16 AM on December 11th, 2009:

    I figured out work around, if you’re using ADIUM… just add your YAHOO buddy using MSN…. as complete email address (for e.g. if your buddy screen name is hotgal4u… you would add it as hotgal4u@yahoo.com).

    What is looks like, Yahoo Messenger servers is blocking all 3rd party connections but then it’s on IM application doesn’t work either. Something is definitely screwed up.

    But apparently, good news for us that MSN and YIM are working with others service well (just like Google Talk & AIM). So, there you have it – hope this helps everyone!

  20. 20 MG said at 1:18 AM on December 11th, 2009:

    I figured out work around, if you’re using ADIUM… just add your YAHOO buddy using MSN…. as complete/exact email address (for e.g. if your buddy screen name is hotgal4u… you would add it as hotgal4u@yahoo.com) – or @ymail.com or @rocketmail.com whichever the situation/email address it might be.

    What is looks like, Yahoo Messenger servers is blocking all 3rd party connections but then it’s own IM application doesn’t work either. Something is definitely screwed up.

    But apparently, good news for us that MSN and YIM are working with others service well (just like Google Talk & AIM). So, there you have it – hope this helps everyone!

  21. 21 dant said at 10:26 PM on February 8th, 2010:

    thanks.. it works!


Leave a Reply